Tuesday, May 20, 2014

[SOLVED] Darwin CalendarServer Install ./bin/develop silently fails

Follow the readme's.

But it's detect_python_version() function isn't looking in the right places for python on Ubuntu.
This causes the CalendarServer/trunk/bin/develop to fail silently and frustratingly.

vim CalendarServer/trunk/bin/_py.sh

in vim do '/detect_python_version' to find the function.

Add these two bold lines at the top of the function:
detect_python_version () {
  echo "/usr/bin/python2.7";   ## or wherever yours is actually located
  return 0;


Then run CalendarServer/trunk/bin/develop again and it should work.

No comments: